Možná jste se s takovýmto problémem už setkali - třeba po instalaci nového počítače. Chtěli jste napsat funkci v Excelu, a ta nefungovala - protože jste chtěli oddělovat parametry středníkem, jak jste zvyklí, ale Excel vyžadoval čárku.

Jinými slovy toto nefunguje:

  • =PRŮMĚR(B1;C1;D1)

ale toto funguje:

  • =PRŮMĚR(B1,C1,D1)

Tento problém je způsobený tím, že v některých státech se používá jako oddělovač parametrů čárka (USA) a někde středník (ČR). U těch prvních se obvykle současně používá jako oddělovač desetinných míst tečka - zatímco u nás čárka.

Řešení je možné v Excelu (návod tady) nebo v celých Windows - viz následující text. 

Začneme tak, že jdeme na Control panel (Ovládací panel). Ve Windows 8 je tato volba mezi aplikacemi:

pristup_control_panel

Ve Windows 7 přímo ve Start menu:
control panel 7
Další postup je víceméně stejný v obou verzích Windows, printscreeny jsou z osmiček. Vyberu, že chci změnit číselné formáty:
zmena_nastaveni
Změním oddělovač seznamu z čárky na středník, a obvykle také oddělovač desetinných míst z tečky na čárku.
dodatecne_nastaveni
Potvrdím a je hotovo. Mimochodem - záměna oddělovacích znamének je často důvodem, proč vám nefunguje vzorec, který jste si zkopírovali z nějakého amerického fóra nebo návodu. Jsou na něm totiž jako oddělovače použité čárky, zatímco váš český Excel chce středníky.

1 Komentář

Napsat komentář

Vaše emailová adresa nebude publikována.

*

smazat formulářOdeslat komentář