S tímto tématem se setkáte na našich kurzech ExcelTown.
Kurzu se můžete zúčastnit prezenčně nebo online.

Příklad

Používám vyhledávací funkci (např. SVYHLEDAT, POZVYHLEDAT...). V některých případech se ale hledaná hodnota nenajde, a pak Excel vrací vcelku nepěknou hlášku #NENI_K_DISPOZICI. Jak to tedy ošetřit?

Návod

Vyhledávací funkci obalíme funkcí IFNA. Tím zajistíme, že v případě nenalezení hodnoty se zobrazí něco jiného - například hláška "hledaná hodnota v seznamu není". Funkce pak vypadá například takto:

  • =IFNA(SVYHLEDAT(A:A;F:G;2;0);"hledaná hodnota v seznamu není")

Asi vás napadne, že stejná věc by šla řešit i pomocí funkce IFERROR. V případě vyhledávacích funkcí je ale použití IFNA čistější - protože IFERROR by pokryl i jiné chyby než nenalezeno, a výsledek nahradil jinou hodnotou. Vy byste se o chybě vůbec nedozvěděli, což obvykle nechcete.

ifna

S tímto tématem se setkáte na našich kurzech ExcelTown.
Kurzu se můžete zúčastnit prezenčně nebo online.

5 Comments

  1. Dobrý den,
    používám excel 2010, kde funkce IFNA není. Jak mohu ve starší verzi excelu vyřešit “stejný” problém, který řešíte v tomto článku. Děkuji

  2. Obdobně bude fungovat iferror… Přesně stejně jako ifna pak bude fungovat toto:
    =KDYŽ(CHYBA.TYP(A1)=7;”nenalezeno”;A1)

  3. Dobrý den, proč podělaný Excel neumí v CZ verzi standardní funkce jako IF, IFNA, COUNT, VLOOKUP? Je to peklo něco udělat v Excelu na počítači, který má bohužel českou lokalizaci a nemohu snadno přepnout na EN. Máte nějaký tip co s tím? Je nutné přeinstalovat Office na normální EN?

  4. Dobrý den, IFNA je ve všech jazycích IFNA. Pokud ji nemáte, zřejmě máte starší verzi Excelu, kde ještě nebyla.
    Ostatní tři je třeba zadávat v české verzi. Většinu verzí Excelu není problém v nastavení přepínat mezi jazyky.

  5. Proč Češi mluví česky? Dobrá otázka. Excel rozhodně snadno mezi jazyky přepínat nelze (zdarma jsou pokud vím akorát screen tipy a supertipy ke stažení plus slovníky pravopisu). Za každou jazykovou verzi prostředí se platí zvlášť. Anglické názvy funkcí v českém Excelu (s původními oddělovači a dalšími nastaveními vázanými na operační systém) je možné používat. Jedná se o jeden lexikon – DLL knihovnu z anglické instalace. U verze 365 bych to třeba ale nedělal kvůli možným aktualizacím.

Napsat komentář

Vaše emailová adresa nebude publikována.

*

smazat formulářOdeslat komentář