Příklad

Mám k dispozici výsledky testů několika žáků. Mohli dosáhnout 0-500 bodů. Podle toho, kolik bodů dosáhli, dostanou známku. Do sta bodů je to pětka, mezi sto a dvě stě bodů čtyřka atd. Výslednou známku chci přiřadit automaticky.

Návod

Připravím si v jedné tabulce seznamy žáků s body a ve druhé intervaly a známky. Pak k prvnímu žákovi napíšu tento vzorec: =SVYHLEDAT(A2;$E$2:$F$6;2;1)
  • A2 - počet bodů tohoto žáka
  • $E$2:$F$6 - oblast s tabulkou, ve které mám rozdělení známek a intervalů
  • 2 - v tabulce se známkami a intervaly jsou ve druhém sloupečku hodnoty, které chci získat
  • 1 - nechci, aby excel hledal přesné hodnoty (protože skoro žádný z žáků neměl přesně 0,100,200,300 ani 400 bodů), ale chci, aby vyhledal nejbližší nižší hodnotu - tedy např. pro 121 vyhledá nejbližší hodnotu 100 a přiřadí čtyřku. V tomto se to odlišuje od běžného (neintervalového) použití SVYHLEDAT A pak už jen roztáhnu na další buňky. Výsledek vypadá takto:
SVYHLEDAT_INTERVAL
Poznámky:

2 Komentářů

  1. Funkce SVYHLEDAT je sice skvělá, ale co když potřebuji hodnoty přiřadit přesně, tedy výslednou známku interpolovat dle přesného počtu bodů. Je to touto funkcí provést, případně je to možné provést jinou funkcí? Děkuji za odpověď.

  2. Jules – to pak stačí dát jako poslední argument téhle funkce nulu místo jedničky

Napsat komentář

Vaše emailová adresa nebude publikována.

*

smazat formulářOdeslat komentář