Tento článek je o funkci VELKÁ2, která upraví text v buňce tak, že všechna slova mají velké první písmeno. Ostatní písmena jsou malá.

Např. ze slova:

  • NEW YORK

udělá:

  • New York

Zápis je jednoduchý, jediným argumentem funkce je text, který se převádí.

velká2

Pro změny velikosti písmen slouží tyto tři funkce:

8 Comments

  1. Dobrý den, mám velký dotaz ohledně velkých a malých písmen v excelu. Potřebovala bych aby při tříslovných názvech měst bylo prostřední malé např. „Blansko nad Strážkou“. Jak na to sestavit vzorec?

  2. Tenhle vzorec nastaví první znak po mezeře jako malé písmeno. Ostatní nechá. Možná by to šlo i nějak šikovněji…
    =NAHRADIT(A1;NAJÍT(“ „;A1)+1;1;MALÁ(ČÁST(A1;NAJÍT(“ „;A1)+1;1)))

  3. Děkuji moc, funguje to na Města tříslovná ale zároveň ne na města která mají jedno nebo dvě slova. Nevíte jak to ošetřit?

  4. =KDYŽ(DÉLKA(A1)-DÉLKA(DOSADIT(A1;“ „;““))=2;NAHRADIT(A1;NAJÍT(“ „;A1)+1;1;MALÁ(ČÁST(A1;NAJÍT(“ „;A1)+1;1)));A1)

  5. Dobrý den,
    řešil jsem obdobný problém také, ale potřebuji toto ošetřit pomocí makra, které nejsem schopen dát dohromady.
    Potřebuji u tříslovných názvů míst ponechat řetězce o délce 1 až 3 znaky malým písmem.
    Například:
    původní „frenštát pod radhoštěm“ opravit na „Frenštát pod Radhoštěm“ a/nebo
    původní: „velký důl u brna“ opravit na „Velký Důl u Brna“
    Lze toto řešit pomocí makra? Nebo pouze podmínkou KDYŽ …….?
    Děkuji předem za radu.

  6. Dobrý den,
    hledám vhodné makro na toto téma a nic. Pokud napíšu:
    Dim Cell As Integer
    On Error Resume Next
    Application.EnableEvents = False
    For Each Cell In Target
    Cell = Proper(Cell)
    Next
    Application.EnableEvents = True
    Vždy mi to vyhodí chybu, co dělám špatně? Prostě chci označit buňku s textem nebo více buněk pod sebou spustit makro aby nechalo počáteční písmena velká a zbytek malá. Děkuji za jakoukoli radu. Nechci to řešit vzorcem.

  7. Sorry za spam – vyřešeno 🙂 Jsem osel….
    Dim x As Range
    For Each x In Range(„B2:B500“)
    x.Value = Application.Proper(x.Value)
    Next
    Hezký den

Napsat komentář

Vaše emailová adresa nebude publikována.

*

smazat formulářOdeslat komentář