Automatický výpočet tolerancí

0
0

Dobrý den,
Mám na Vás velkou prosbu. Potřebuji napsat vzorec, který mi na základě zapsaného výsledku vypočítá o kolik je výsledek mimo tolerance. Pokud je výsledek v tolerancích tak zapsat "OK". Výsledek může být jak do - mimo tolerance tak do +. Vzorec s tím musí umět pracovat. V tomto případě pracujeme s hodnotou 100 ± 1 tedy tolerančním pásmem 101 až 99. Pokud nebude vyplněný výsledek, tak by měla zůstat bunka prázdná. Jde o automatický výpočet zda je hodnota OK nebo ne a když ne tak o kolik. Příklad: [Bunka 1_Nominální hodnota "100"]; [Bunka 2_Tolerance do + "1"]; [Bunka 3_Tolerance do - "1"]; [Bunka 4_Výsledek "102"]; [Bunka 5_Požadovaný vzorec "1"];;; Pokud bude výsledek 98 -> [Bunka 5_Požadovaný vzorec "-1"];;; Pokud bude výsledek mezi 10199 -> [Bunka 5_Požadovaný vzorec "OK"];;; Pokud NEBUDE zapsán výsledek [Bunka 4] -> [Bunka 5_Požadovaný vzorec " "] ... snad jsem to napsal alespon trochu srozumitelně. Moc děkuji ! Jakub

Marked as spam
Odeslal Jakub011
Otázka položena 5.3.2019 11:32
28 views
0
Private answer

Zkusím to napsat znovu trošku jinak.
bunka A2 = nominální hodnota zapsaná jako "100"
bunka B2 = tolerance do + zapsaná jako "1"
bunka C2 = tolerance do - zapsaná jako "1"
bunka D2 = naměřený výsledek "102"
bunka E2 = VZOREC
Potřebuji aby mi vzorec zohlednoval následující. Je D2 větší než A2+B2? -> ANO o "1" , Je D2 menší než A2-C2? -> ANO o kolik? "číslo", Je hodnota D2 mezi hodnotou A2+B2 a A2-C2 ? -> ANO napsat "OK" Není zadána v bunce D2 žádná hodnota? -> ANO nechat bunku prázdnout

Marked as spam
Odeslal Anonymous
Odpověděl 5.3.2019 13:20
0
Private answer

E2: =KDYŽ(D2"";KDYŽ(D2=0;"OK";D2-(A2+C2)));"")

Marked as spam
Odeslal xlnc
Odpověděl 5.3.2019 19:19
0
Private answer

Tady bohužel PHP ořezává vložený vzorec, takže sešit: https://uloz.to/!R1dKKwajF4k3/intervalek-xlsx

Marked as spam
Odeslal xlnc
Odpověděl 5.3.2019 19:25
0
Private answer

Děkuji za pomoc ! :-)

Marked as spam
Odeslal Anonymous
Odpověděl 7.3.2019 6:32

Odešlete svou odpověď

Attach YouTube/Vimeo clip putting the URL in brackets: [https://youtu.be/Zkdf3kaso]