Číslo v Textu

0
0

Dobrý den,

potřebuji pomoc - hledám už asi hodinu možnost jak napsat následující vzorec: Př. v A1 mám text CD12 v A2 mám text CD8 v A3 mám text C8

potřebuji aby v buňkách B1 B2 B3 bylo jen číslo ze sloupce A to znamená že pokud: A1=CD12 > B1=12 A2=CD8 > B2=8 A3=C8 > B3=8 s funkcí =ZPRAVA to nejde, můžu to udělat třeba =KDYŽ(A1="CD12";12) a tak dále do nekonečna jenže těch druhů je tolik, že bych se upsal

Děkuji za radu

Marked as spam
Odeslal Lukáš Suchánek
Otázka položena 11.12.2017 13:29
61 views
0
Private answer
Pro A1: =–ZPRAVA(A1;SOUČIN.SKALÁRNÍ((DÉLKA(A1)-DÉLKA(DOSADIT(A1;{0123456789};““)))))
Marked as spam
Odeslal Anonymous
Odpověděl 12.12.2017 14:27
0
Private answer
Tento vzorec mi nefunguje :/ Děkuji
Marked as spam
Odeslal Anonymous
Odpověděl 13.12.2017 14:21
0
Private answer
Do B1 dej =KDYŽ(JE.ČISLO(HODNOTA(A1));A1;ZPRAVA(A1;DÉLKA(A1)-1)) a přetáhni směrem doprava o tolik polí, jak je dlouhý nejdelší řetězec. Postupně se zleva odříznou písmena až zůstanou pouze čísla. Funguje i na kombinaci čísla písmena. Zůstane jen číslo zprava.
Marked as spam
Odeslal Yogi Bear
Odpověděl 13.12.2017 22:25
0
Private answer
No jo, vzorec zdejší plugin pro fórum doprasil…
Marked as spam
Odeslal Anonymous
Odpověděl 14.12.2017 20:40

Odešlete svou odpověď

Attach YouTube/Vimeo clip putting the URL in brackets: [https://youtu.be/Zkdf3kaso]