Funkce kdyz a zaroven

0
0

Dobry den, muzete mi prosim poradit s funkci. Mam 3bunky: 1 bunka - pocet ks, 2 bunka - cena za ks, 3 bunka - pocita se obrat ( bunka 1x bunka 2). Jakou mam prosim pouzit funkci ktera by me upozornila pri vyplneni bunky 1 ( poctu ks ) , ze jsem zapomnel zadat cenu ( bunka 2) a tim se nedopocital obrat v bunce . Jak tento vzorek bude vypadat. Dekuji. Swoop

Marked as spam
Odeslal swoop
Otázka položena 18.3.2016 2:05
2839 views
0
Private answer
Na to pomůže funkce resp. kombinace několika funkcí: KDYŽ(NEBO(A(JE.PRÁZDNÉ(cena);NE(JE.PRÁZDNÉ(počet));A(JE.PRÁZDNÉ(počet);NE(JE.PRÁZDNÉ(cena));”Zadán 1 údaj”);počet*cena)) Doufám, že jsem dobře spočítal závorky – jinak to ber jako inspiraci. Případné dotazy na excelcz-forum@googlegroups.com
Marked as spam
Odeslal Lubek
Odpověděl 24.3.2016 16:53
0
Private answer

Lubek – to je hrozně překomplikované. Tenhle vzorec funguje stejně:
=KDYŽ((A1>0)+(B1>0)=1;”něco chybí”;A1*B1)
(Pokud máte cenu a počet v A1 a B1)
Stačí využít toho, že Excel umí pracovat s výsledky logických tvrzení jako s čísly 1 nebo 0. Další krátká možnost by byla např.:
=KDYŽ(COUNTIFS(A1:B1;”>0″)=1;”něco chybí”;A1*B1)

Marked as spam
Odeslal (Otázky: 1, Odpovědi: 188)
Odpověděl 24.3.2016 18:54

Odešlete svou odpověď

Attach YouTube/Vimeo clip putting the URL in brackets: [https://youtu.be/Zkdf3kaso]