0
0

Ahoj, mám tu jeden takový složitý excelovský úkol. Jsem průměrný uživatel a nevím si rady.
Mám vytvořenou zdrojovou tabulku cca 10 sloupců x řekněme 1000 řádků a potřebuji vytvořit vzorec pro najití shody celého řádku. Jedná se o jakousi "kalkulačku", kde si uživatel rolovacím seznamem postupně volí parametry (všech 10, celý řádek), a ze zdrojové tabulky se má najít přesná shoda řádků. Jako výsledek stačí jen odpověď ANO / NE, zda je zvolená kombinace ve zdrojové tabulce.
Pořadí musí být zachováno. Dejme tomu, zdrojová tabulka jsou kombinace deseti různých čísel. Uživatel si v rolovacím seznamu postupně volí čísla. Cílem je najít, zda Uživatelova zvolená kombinace odpovídá jedné z těch 1000 možných.
Mockrát děkuji za radu

Marked as spam
Odeslal VM
Otázka položena 16.12.2019 12:41
56 views
0
Private answer

Ještě doplňuji - nejspíš k tomu půjde přistoupit také kombinací funkcí KDYŽ, A, NEBO. Zkouším to, ale je to strašně krkolomné, navíc se mi to nedaří rozchodit. Potřebuji zapsat něco v tomto smyslu: KDYŽ v buňce C1 bude něco, (A) v D1 něco, (A) v E1 něco (NEBO) něco (NEBO) něco, v F1 něco, je to PRAVDA. V opačném případě NEPRAVDA. Problém je zřejmě v tom NEBO, které navíc kombinuji s funkcí ZLEVA a ZPRAVA.
Zasílám zápis přímo z excelu:
=KDYŽ(A(C32=K5;D32>=L5;D32=P5;D34=S5;D35<=T5;(D34+D35)<=V5;(NEBO(E36=(ZLEVA(W5;1));(ZPRAVA(W5;1)))));PRAVDA;NEPRAVDA) A toto, až bude fungovat, zkombinovat s funkcí typu VVyhledat, která najde ten správný řádek. Půjde to takto? Díky

Marked as spam
Odeslal VM
Odpověděl 17.12.2019 14:25
0
Private answer

=KDYŽ(A(C32=K5;D32>=L5;D32=P5;D34=S5;D35<=T5;(D34+D35)<=V5;(NEBO(E36=(ZLEVA(W5;1));E36=(ZPRAVA(W5;1)))));PRAVDA;NEPRAVDA)

Marked as spam
Odeslal JoKe
Odpověděl 17.12.2019 20:01
0
Private answer

pokud jsem Vás pochopila, zkuste si výsledné hodnoty jednotlivých polí v řádku sloučit do jednoho pole =A1&B1&C1&D1&E1... tím z jednotlivých čísel 1 2 3 4 5 získáte kombinaci 12345, tu pak můžete přes další funkci ideálně asi Svyshledat přiřadit k danému řádku

Marked as spam
Odeslal Eli
Odpověděl 17.12.2019 21:27

Odešlete svou odpověď

Attach YouTube/Vimeo clip putting the URL in brackets: [https://youtu.be/Zkdf3kaso]