Hodnoty z oblasti podle daného čísla

0
0

Dobrý den,

chtěl bych se zeptat jak můžu zajistit toto:

mám počet % za určitý den: 1. Den = 40% 2. Den = 30% 3. Den = 90%

Mám taktéž tendence: 1. Den = 40% 2. Den = 35% (40%+30%/Počtem dní) 3. Den = 53,33% ((40%+30%+90%/Počtem dní)

Jak funkcí (či vzorečkem) můžu zajistit, aby z oblasti kterou určím si to vzalo jenom určený počet dní?

např. Když napíšu do buňky, ze kterého se tato data berou číslo 2, aby mě to vrátilo těch 35%, kdybych tam napsal číslo 1 tak těch 35% a kdyby číslo 3 tak těch 53,33%

Děkuji

Marked as spam
Odeslal Dxnxex
Otázka položena 8.2.2018 12:53
34 views
0
Private answer
Lze použít vzorec: „=SUMIFS(B1:B3;A1:A3;CONCATENATE(„<=";C1))/C1", kde ve sloupci A jsou čísla dnů, ve sloupci B procenta a v buňce C1 se zvolí počet dnů. Vzorec provede součet všech hodnot ve sloupci B, kde je splněna podmínka čísla dne rovného nebo menšího hodnoty C1. Buňku se vzorcem je vhodné naformátovat v procentech.
Marked as spam
Odeslal HH
Odpověděl 23.2.2018 9:47
0
Private answer
Stejný a trochu elegantnější je ještě tento způsob pomocí skalárního součtu: „=SOUČIN.SKALÁRNÍ((A1:A3<=C1)*(B1:B3))/C1".Vzorec sčítá hodnoty ve sloupci B pouze tehdy pokud je ve sloupci A číslo menší nebo rovno hodnotě C1.
Marked as spam
Odeslal HH
Odpověděl 23.2.2018 12:01

Odešlete svou odpověď

Attach YouTube/Vimeo clip putting the URL in brackets: [https://youtu.be/Zkdf3kaso]