MAX/MIN – LARGE/SMALL

0
0

Bohužel při napsání vzorce {=MIN(KDYŽ(A:A=C6;B:B))} se mi ve výsledku objevuje 0 :-(. (a 0 nemám ve sloupci B:B vůbec obsaženou) Přitom když napíši vzorec {=MAX(KDYŽ(A:A=C6;B:B))} tak získávám správný výsledek. To samé platí při napsání pro LARGE a SMALL. U LARGE vše funguje, u SMALL je vždy výsledek 0.

Víte někdo důvod chyby? Předem moc děkuju.

Marked as spam
Odeslal memu
Otázka položena 8.6.2017 5:45
70 views
0
Private answer
Jaké hodnoty máte v procházeném sloupci? Pokud tam jsou čísla s desetinnými místy, může se např. 0,4 zobrazovat ve výsledku jako 0 pokud máte nastavené formátování buňky pouze na 0 desetinných míst (zakrouhlení). Přitom je to správný výsledek.
Marked as spam
Odeslal Anonymous
Odpověděl 8.6.2017 19:39
0
Private answer
NEN VŠE TAM MÁM SPRÁVNĚ NAPSANÉ – PODOBNÝ VZOREC JEN S ROZDÍLNÝMI FUNKCEMI (MÍSTO MIN JE MAX A NEBO LARGE) A FUNGUJETE. DATA TAHÁM Z JEDNÉ A TÉ SAMÉ TABULKY, TAKŽE ZÁPISEM HODNOT TO BÝT NEMŮŽE. KDYŽ ALE ZKOUŠÍM VZOREC NA JEDNOM LISTĚ, TAK VŠE FUNGUJE BEZ PROBLÉMU. JAKMILE CHCI UVÉST VZOREC DO PRAXE (TABULKA NA LISTĚ 1 KAM PÍŠI VZOREC, DATA JSOU V TABULCE NA LISTĚ 2 V JEDNOM SEŠITU), TAK TO UŽ NEFUNGUJE – NĚJAKÉ NÁPADY JAK TENTO PROBLÉM POŘEŠIT A NEBO OBEJÍT? JEN PRO INFORMACI – TAKTO VYPADÁ VZOREC PRO NEJNIŽŠÍ HODNOTU… {=KDYŽ(IFERROR(LARGE(KDYŽ(‚list2′!B11:B23=’list1′!C6;’CCRs AEB City‘!E11:G23);1);MAX(KDYŽ(‚list2′!B11:B23=’list1′!C6;’list2‘!E11:G23)));IFERROR(MAX(KDYŽ(‚list2′!B11:B23=’list1′!C6;’list2′!E11:G23));’list1‘!C6);0)}
Marked as spam
Odeslal memu
Odpověděl 9.6.2017 10:05
0
Private answer
jé špatně, nakopíroval jsem vzorec pro maximální hodnotu :D….ale jinak je vzorec stejný, jen tam místo MAX je všude MIN….když MIN nefunguje, zkoušel jsem i funkci SMALL.
Marked as spam
Odeslal memu
Odpověděl 9.6.2017 10:07

Odešlete svou odpověď

Attach YouTube/Vimeo clip putting the URL in brackets: [https://youtu.be/Zkdf3kaso]