0
0

Ahoj, prosím Vás o radu s excelem:
Potřeboval bych vědět jak přiřadit znak na první místo všech buněk které mají jen 4 znaky. Přiřazený znak bude vždy číslo 9.
mám sloupec A naplněný daty:
12345
02345
AB123
2345
muj postup
Počet znaku si vypíšu funkcí délka do slupce B. Vím tedy kde jsou jen 4 znaky. Nyní bych potřeboval podmínku která vyřeší: když B = 4 tak přidej 9 k číslu v bunce A.
Výsledek tedy bude:
12345
02345
AB123
92345
Nebo se to dá vyřešit jinak? díky za rady

Marked as spam
Odeslal Lukas
Otázka položena 3.5.2021 9:30
49 views
0
Private answer

B1: =KDYŽ(DÉLKA(A1)=4;9&A1;A1)
Pokud tam máte tu úvodní nulu, tak předpokládám, že s tím zacházíte jako s texty, ne čísly.

Marked as spam
Odeslal xlnc
Odpověděl 4.5.2021 6:58
0
Private answer

Dobrý den, funkční díky

Marked as spam
Odeslal Lukas
Odpověděl 4.5.2021 17:51
0
Private answer

Tohle se dá docela hezky i zobecnit, pokud chcete, aby vám to doplnilo tolik devítek, kolik je třeba. Tedy i když je původně třeba 1-5 znaků, tak se to devítkami doplní na pět.
=OPAKOVAT(9;5-DÉLKA(A1))&A1

Marked as spam
Admin bar avatar Odeslal (Otázky: 1, Odpovědi: 331)
Odpověděl 7.5.2021 11:20

Odešlete svou odpověď

Attach YouTube/Vimeo clip putting the URL in brackets: [https://youtu.be/Zkdf3kaso]