Součet ve stejném řádku (buňce)

0
0

Dobrý den,

rád bych se zeptal na možnost součtu hodnot ve stejné buňce řádku (např. mám ve sloupci D na řádku 4 hodnoty: 1 1 1 1 1 a chci zjistit, kolik celkem je tam součet nebo počet daných hodnot). Funkcí SUMA nebo COUNTIF to nejde, protože se jedná o operaci v jedné buňce.

Díky moc za pomoc!

Marked as spam
Odeslal nimbuuss
Otázka položena 13.5.2019 6:42
46 views
0
Private answer

Zadání je neuplné, co ostatní znaky, případně nuly atd., každopádně existují třeba maticové vzorce pro parsování znaků v buňce. Tady by mohla zafungovat ale jiná věc - postavit se k tomu jako k číslu (dekadické, možná binární), pohrát si s řády apod. Není ale jasné, z čeho všeho může řetězec/číslo v buňce sestávat.

Marked as spam
Odeslal xlnc
Odpověděl 13.5.2019 20:25
0
Private answer

Jinak Google a "sum digits in cell"

Marked as spam
Odeslal xlnc
Odpověděl 13.5.2019 20:35
0
Private answer

https://exceltown.com/navody/funkce/delka-len-delka-textu-v-bunce/
Tohle by mohlo pomoct

Marked as spam
Odeslal (Otázky: 1, Odpovědi: 230)
Odpověděl 15.5.2019 5:09
0
Private answer

Za předpokladu, že v buňce B1 jsou cifry oddělené mezerami, do jiné buňky pak maticový vzorec:
=SUMA(HODNOTA(ČÁST(DOSADIT(B1;" ";"");ŘÁDEK(A1:POSUN(A1;DÉLKA(DOSADIT(B1;" ";""))-1;0));1)))
nezáleží, myslím, na tom, zda sloupec A obsahuje nějaké hodnoty. Částečně jsem použil předchozí odpovědi a dotáhl. Počet cifer v buňce je snad jasný, délka bez mezer.

Marked as spam
Odeslal w.cz
Odpověděl 15.5.2019 7:05

Odešlete svou odpověď

Attach YouTube/Vimeo clip putting the URL in brackets: [https://youtu.be/Zkdf3kaso]