0
0

Dobrý den. Mám sloupec, řekněme že je to sloupec A, o cca. 4000 řádcích, ve kterém jsou jednak datumy ve formátu DD.MM.RRRR a dále jsou v něm textyp, časy a další hodnoty. Potřebuji vedle vytvořit druhý sloupec B, ve kterém budou pouze datumy. Tj. tam, kde je na daném řádku ve sloupci A v buňce datum ve formátu DD.MM.RRRR, potřebuji ve sloupci B obsah buňky ve sloupci A.
Pokud je ve sloupci A na daném řádku cokoli jiného než datum, pak ve sloupci B na daném řádku potřebuji stejné datum jaké bylo v předchozím řádku. Chtěl jsem to vyřešit funkcí pro buňku B2: =KDYŽ(DATUMHODN(A2)>0;A2;B1) a tu pak rozkopírovat na další řádky ve sloupci B (nutným předpokladem je, že v buňce A2 je datum ve formátu DD.MM.RRRR - to je splnitelný předpoklad)
Bohužel, pokud je ve sloupci A na kterémkoli řádku něco jiného než datum, funkce vrátí "#HODNOTA".
Prosím o radu, jakou funkci použít, abych dostal jako výsledek funkce KDYŽ hodnotu NEPRAVDA, pokud v dotazované buňce bude něco jiného než datum. Děkuji

Marked as spam
Odeslal Miro69
Otázka položena 9.3.2020 19:35
25 views
0
Private answer

Dobrý den,
nejsem si jistý jestli úplně chápu logiku celého příkladu, ale myslím že by se Vám mohly hodit funkce IFERROR nebo případně ISERROR:
https://exceltown.com/navody/funkce/iferror-v-pripade-chyby-vrati-urcitou-hodnotu/
https://exceltown.com/navody/funkce/je-cislo-je-chyba-je-chybhodn-je-loghodn-je-nedef-je-netext-je-odkaz-je-prazdne-je-text/

Marked as spam
Odeslal (Otázky: 1, Odpovědi: 255)
Odpověděl 10.3.2020 8:01
0
Private answer

Pro data od A2:
=KDYŽ(POLÍČKO("formát";A2)="D1";A2;B1)
D1 není adresa buňky, ale kód formátu Datum. Data ve sloupci A musí začínat datem.

Marked as spam
Odeslal Janku
Odpověděl 20.3.2020 18:59

Odešlete svou odpověď

Attach YouTube/Vimeo clip putting the URL in brackets: [https://youtu.be/Zkdf3kaso]