Vypsání neprázdných buněk

0
0

Dobrý den, excel není můj obor a patřeboval bych poradit. Mám sloupec A v němž je mnoho prázdných buněk a hodnota "1". A já potřebuji, aby v případě, že je "1", napsal do hodnotu ze sloupce "B" do "C", přičemž vynechá prázdné řádky. Nemohu to řešit makrem. Děkuji za rady, vím, že by pomohlo přečíst si manuál, ale používám excel minimálně.

Marked as spam
Odeslal tomas
Otázka položena 9.6.2016 9:10
128 views
0
Private answer
Marked as spam
Odeslal unknown (Otázky: 0, Odpovědi: 2)
Odpověděl 9.6.2016 9:11
0
Private answer
Děkuji, ale toto nemohu řešit filtrem. Potřebuji čisté řešení. Nechci to řešit ani makrem a jsem si skoro jist, že excel je dost silný, aby to uměl. Bohužel já ne a nevím jak donutit INDEX a POZVYHLEDAT, aby to psali pod sebe a nechali prázdné řádky.
Marked as spam
Odeslal tomas
Odpověděl 9.6.2016 9:27
0
Private answer

A co je na rozšířeném filtru nečistého? Jsem si téměř jistý, že s funkcí INDEX a POZVYHLEDAT se Vám to nepovede – alespoň ne bz řady pomocných mezivýpočtů…

Marked as spam
Odeslal unknown (Otázky: 0, Odpovědi: 2)
Odpověděl 9.6.2016 9:29
0
Private answer
Protože filt mi sám od sebe nezaregistruje, že je tam další hodnota a já s výsledkem potřebuji dále počítat. Tzn. bude tam pořád x řádek, nikoli x+1.
Marked as spam
Odeslal tomas
Odpověděl 9.6.2016 9:33
0
Private answer
To TOMAS Do sloupce C vzorec: =KDYŽ(A1>0;B1;””) Taky funguje: =KDYŽ(A1;B1;””)
Marked as spam
Odeslal TORES
Odpověděl 9.6.2016 9:37
0
Private answer

TORES – já nevím, jestli je tohle přesně to, na co se Tomáš ptá. Řeší to i na tomto diskusním fóru:
http://answers.microsoft.com/en-us/office/forum/office_2003-excel/removing-blank-cells-with-a-formula/c5a9845d-b335-4d92-b459-eff4ebc9e4f2
ale opravdu to nesměřuje k žádnému jednoduchém použití INDEX POZVYHLEDAT, bude to asi výrazně složitější…

Marked as spam
Odeslal (Otázky: 1, Odpovědi: 176)
Odpověděl 9.6.2016 9:46
0
Private answer
Děkuji, to fórum jsem při googlení nenašel, ale je to přesně to ono.
Marked as spam
Odeslal Tomas
Odpověděl 9.6.2016 9:52

Odešlete svou odpověď

Attach YouTube/Vimeo clip putting the URL in brackets: [https://youtu.be/Zkdf3kaso]