S tímto tématem se setkáte na našich kurzech ExcelTown.
Vzhledem k uvolnění opatření kolem koronaviru předpokládáme, že se kurzy budou normálně konat.

Tento článek je o tom, že prvním argumentem funkce KDYŽ / IF může být samotné číslo bez podmínky.

Předpokládejme, že chceme do buňky B1 zachytit pomocí funkce KDYŽ pravidlo:

  • KDYŽ je v buňce A1 jakékoliv číslo větší než nula, napiš "je číslo", jinak napiš "není číslo".

Takové pravidlo se dá zapsat např. takto:

  • =KDYŽ(A1>0;"je číslo";"není číslo")

ale také tímto kratším způsobem:

  • =KDYŽ(A1;"je číslo";"není číslo")

Funkce KDYŽ totiž vyhodnocuje jako pravdu nejen tvrzení, které je splněné (má hodnotu PRAVDA), ale také jakékoliv číslo různé od nuly. Číslo může být i záporné nebo desetinné, jen to nesmí být nula.

Toto se typicky použíje např. v situaci, kdy chceme určit, jestli se např. hodnota "XY" vyskytuje ve sloupci B. Vzorec vypadá takto:

  • =KDYŽ(COUNTIFS(B:B;"XY");"v béčku někde je XY";"v béčku XY není")
S tímto tématem se setkáte na našich kurzech ExcelTown.
Vzhledem k uvolnění opatření kolem koronaviru předpokládáme, že se kurzy budou normálně konat.