Představte si, že potřebujete zjistit, jestli slovo obsahuje určitý textový znak. Např. tady potřebujete určit, jestli buňka obsahuje někde v textu slovo "limonáda"..

Jak to zjistit?

Pokud víte, jak fungují zástupné znaky a funkce KDYŽ / IF, nabízelo by se použít tento vzorec:

  • =KDYŽ(A2="*limonáda*";"Je limonáda";"Není limonáda"):

Jenomže to nebude fungovat, protože funkce KDYŽ / IF neumí se zástupnými symboly pracovat.

Tak jak na to?

Přidáme (např.) funkci COUNTIFS, která zástupné symboly umí.

  • =KDYŽ(COUNTIFS(A2;"*limonáda*");"Je limonáda";"Není limonáda")

Funkce COUNTIFS si pak vezme text, zjistí, jestli buňka obsahuje (kdekoliv v sobě) slovo "limonáda", a předá funkci KDYŽ jedničku nebo nulu. Funkce KDYŽ pak normálně vrátí první nebo druhou možnost.

1 Komentář

  1. Práce se zástupnými zraky ve funkcích je drobet zrádná. Kromě hvězdičky a otazníku k nim patří ještě tilda. Tu ovšem nezvládá podle mých zkušeností ani jedna z funkcí listu. S otazníkem má problémy kupříkladu funkce DPOČET2 (vrací nesmysly).

Napsat komentář

Vaše emailová adresa nebude publikována.

*

smazat formulářOdeslat komentář